I suggest you ...

ON SCHEDULE should be renamed to make the intent intuitive

On the General Tab of Task, there is a parameter named On Schedule. This parameter could be ticked or left. As a new user of CentriQS, I thought that the meaning or intent of the parameter was to check if the task was on schedule. In a program, variable naming is extremely crucial in terms of making the program more user friendly.

Now, let's get into the matter.

The parameter, as it turns out, will cause the Remaining argument to be recalculated. In other words, it will cause the program to indicate the time remaining till the Due Date.

In order to keep the intent of the developers in place as well as to simplify the easy of understanding, I would suggest that the parameter be renamed to Recalculate Time Remaining. If the user wants to recalculate the remaining time, then the box would have to be ticked which will satisfy the vision of the developers.

1 vote
Sign in
Signed in as (Sign out)
You have left! (?) (thinking…)
Baliso VubaBaliso Vuba shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
Signed in as (Sign out)
  • CentriqsAdminCentriqs (Admin, CentriQS) commented  ·   ·  Flag as inappropriate

    We agree that term “On Schedule” is not the most intuitive however the option “On Schedule” does not recalculate the remaining duration as time left till Due Date. It recalculates remain by the following formula:

    Remain = Estimate – Actual.

    Before we chose the term “On Schedule” we called this option “Auto-Calculate”. Do you think it will be better to rename “On Schedule” into “Auto-Calculate”?

Feedback and Knowledge Base